易语言教程-简单POST注册冒险岛私服(易语言网页操作新手必看)

  • A+
所属分类:电脑网络

首先强调,我是易语言方面的新手(每次都强悍,这样就不会被高手喷了)。作为学习易语言的一分子,首先要明确自己学习易语言的哪一类的东西(比如我是学网页操作的),也就是给自己学习制定一个方向,这样就会少走很多弯路。就拿我来说,像那些数据库呀什么的就不需要去看了!在此老张博客也给易语言新手一些建议吧:大道理不讲,只要记住,多看教程多实践,在实践中去领悟!就这一点!

言归正传,今天主要是和大家分享简单POST应用。这里不提供语音教程,只提供源码,但是在源码里,我讲解的非常清楚,连最基本的命令都有和大家说!

网页操作POST两大基本步骤:一抓包,二发包。

抓包:在你需要互动的网页(比如注册、发帖等)填写好需要的内容(比如注册时需要填写的用户名、密码、邮箱等等)与服务器进行互动操作,在操作过程中利用抓包工具把数抓取下来。常用的抓包工具有:精易编程助手、Wireshark、httpwatch、WSockExpert等。

发包:利用精易模块中的一个命令“网页_访问”(各模块命令不同)来把你所修改后的数据包发送,以达到交互操作的目的!

代码:

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 提交数据, 文本型, , , 存放POST数据
.局部变量 返回数据, 文本型, , , 存放发包后返回网页数据

提交数据 = “username=” + 编辑框1.内容 + “&password=” + 编辑框4.内容 + “&cpassword=” + 编辑框4.内容 + “&mail=” + 编辑框3.内容 + “&QQ=” + 编辑框2.内容 + “&gender=2&regpost=ok&reg=%D7%A2%B2%E1”
' 上段代码是把抓包工具抓取的数据进行修改,如“编辑框内容”这些都是需要修改的部分,具体操作需要看你交互式网页的内容。
返回数据 = 到文本 (网页_访问 (“http://zz.somxd.com/register.php?page=register”, 1, , , 到字节集 (提交数据)))
' 1、“网页_访问”,这一命令可以说是网页操作必用的命令,共有8个参数。需要注意的参数就是访问网址、提前方式、提交数据等。重点:需返回值为字节集。
' 2、正因为“网页_访问”返回的是字节集,所以才需要将其转成文本型。
.判断开始 (寻找文本 (返回数据, “您的账号已经创建完毕,并且可以进入游戏”, , 假) ≠ -1)
    信息框 (“注册成功”, 0, )
.默认
    信息框 (“注册失败”, 0, )

.判断结束
' “寻找文本”这一命令,用来找注册成功的字样。三个参数:第1为欲找源文本,第二参数为欲找文本内容。
' 特别提醒:“寻找文本”这一命令返回的是整数型。找到了返回“1”,没找到返回“-1”

源码下载地址:http://115.com/file/anmqw215#简单POST注册冒险岛私服.e

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: