易语言源码-随机取混合密码-超新手教程

  • A+
所属分类:电脑网络

首先强调的是这算不上是易语言教程,因为我是易语言的超新手,这个只能算得上是我的学习笔记!

我在易语言方面主要是学习网页操作方面,其中不少涉及到“注册机”之类的东西,而注册机中就有填写密码时有两种方式,一是用户自定义密码,而另外一种就是取随机密码。这个源码,就是怎么样取大写字母、小写字母、数字组合的的混合文本的。

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 取密码, 文本型, , , 用来存放所取得的密码
.计次循环首 (10, )  ' 循环10次,每循环一次,密码倍数都增加
    取密码 = 取密码 + 多项选择 (取随机数 (1, 3), 字符 (取随机数 (65, 65 + 25)), 字符 (取随机数 (97, 97 + 25)), 字符 (取随机数 (48, 57)))
    ' 上段代码中"多项选择“即为随机选择大写字母、小写字母、数字
    ' 字符 (取随机数 (65, 65 + 25))随机取小写字母
    ' 字符 (取随机数 (97, 97 + 25))随机取大写字母
    ' 字符 (取随机数 (48, 57))随机取数字
    ' 此三段中的“字符”中取随机数,是取ASCII代码,具体可见ASCII代码参见表
.计次循环尾 ()
' ------------------------------------------------------------
编辑框1.内容 = 编辑框1.内容 + 取密码 + #换行符
编辑框1.加入文本 (取密码 + #换行符)
' 注:此两段代码都是实现在编辑框中增加所取的10位随机密码,
' 但是第一段是变量赋值形式,运行时编辑框中优先显示前几次结果
' 第二段是命令形式,运行中编辑框中优先显示最后显示结果
' 建议用第二种方式来进行操作

 

 

源码下载:http://115.com/file/anm4b3nt

历史上的今天
三月
15

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:1   其中:访客  1   博主  0

    • avatar 同城交友 1

      不错啊,支持下。